qjail does not work on DragonflyBSD

@aintek on Wed Jan 09 2019
2.1 min

Toc

Installed jqail by pkg, but qjail does not work.

What’s happen?

My DragonflyBSD is 5.2-RELEASE, can use pkg command.
When installing qjail, command was failed.

$ sudo pkg install qjail
Error: The Host is running 5.2-RELEASE.
This version of qjail only runs on 11.0-RELEASE or newer.
qjail4-4.9 version is the last qjail version to handle the
10.x release series.

Conclusion

pkg’s qjail is not used on DragonflyBSD yet because qjail deal with freebsd only.
In qjail code remains freebsd’s code at col:1897 and so on.
If commenting out at col:1897, qjail gets base.txz from http://ftp2.freebsd.org/pub/FreeBSD/releases/${release}/base.txz. ${release} has DragonflyBSD’s version 5.2-RELASE.

Only use traditional jail…
reference: Dragonflybsd - jail

日別に記事を見る
興味のあるタイトルをクリック